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[bookmark: MonDebut][bookmark: _Toc342409980][bookmark: _Toc237231758]Introduction
After reading this introduction, you will know how to:
Use manual in general.
Use prerequisites, a target student description, course objectives, and a skills inventory to properly set your expectations for the course.
Re-key this course after class.
[bookmark: _Toc342409981]Topic A: About the manual
philosophy
Our manuals facilitate your learning by providing structured interaction with the software itself. While we provide text to explain difficult concepts, the hands-on activities are the focus of our courses. By paying close attention as your instructor leads you through these activities, you will learn the skills and concepts effectively.
We believe strongly in the instructor-led class. During class, focus on your instructor. Our manuals are designed and written to facilitate your interaction with your instructor, and not to call attention to manuals themselves.
We believe in the basic approach of setting expectations, delivering instruction, and providing summary and review afterwards. For this reason, lessons begin with objectives and end with summaries. We also provide overall course objectives and a course summary to provide both an introduction to and closure on the entire course.
Manual components
The manuals contain these major components:
Table of contents
Introduction
Units
Course summary
Glossary
Index
Each element is described below.
[bookmark: _Toc342409982]Introduction
The introduction contains information about our training philosophy and our manual components, features, and conventions. It contains target student, prerequisite, objective, and setup information for the specific course.
Units
Units are the largest structural component of the course content. A unit begins with a title page that lists objectives for each major subdivision, or topic, within the unit. Within each topic, conceptual and explanatory information alternates with hands-on activities. Units conclude with a summary comprising one paragraph for each topic, and an independent practice activity that gives you an opportunity to practice the skills you’ve learned.
The conceptual information takes the form of text paragraphs, exhibits, lists, and tables. The activities are structured in two columns, one telling you what to do, the other providing explanations, descriptions, and graphics.
Course summaryIntroduction	v

This section provides a text summary of the entire course. It is useful for providing closure at the end of the course. The course summary also indicates the next course in this series, if there is one, and lists additional resources you might find useful as you continue to learn about the software.
Glossary
The glossary provides definitions for all of the key terms used in this course. Index
The index at the end of this manual makes it easy for you to find information about a particular software component, feature, or concept.
Manual conventions
We’ve tried to keep the number of elements and the types of formatting to a minimum in the manuals. This aids in clarity and makes the manuals more classically elegant looking. But there are some conventions and icons you should know about.
Item	Description
Italic text	In conceptual text, indicates a new term or feature.
Bold text	In unit summaries, indicates a key term or concept. In
an independent practice activity, indicates an explicit item that you select, choose, or type.
Code font	Indicates code or syntax.
Longer strings of ►	In the hands-on activities, any code that’s too long to fit
code will look ►	on a single line is divided into segments by one or more
like this.	continuation characters (►). This code should be
entered as a continuous string of text.
Select bold item	In the left column of hands-on activities, bold sans-serif
text indicates an explicit item that you select, choose, or type.
Keycaps like H ENTER)	Indicate a key on the keyboard you must press.
[bookmark: _Toc342409983]Hands-on activities
The hands-on activities are the most important parts of our manuals. They are divided into two primary columns. The “Here’s how” column gives short instructions to you about what to do. The “Here’s why” column provides explanations, graphics, and clarifications. Here’s a sample:
Do it!	A-1: Creating a commission formula - Here’s how	Here’s why

1 Open Sales	This is an oversimplified sales compensation
worksheet. It shows sales totals, commissions, and incentives for five sales reps.
2 Observe the contents of cell F4
The commission rate formulas use the name “C_Rate” instead of a value for the commission rate.

For these activities, we have provided a collection of data files designed to help you learn each skill in a real-world business context. As you work through the activities, you will modify and update these files. Of course, you might make a mistake and therefore want to re-key the activity starting from scratch. To make it easy to start over, you will rename each data file at the end of the first activity in which the file is modified. Our convention for renaming files is to add the word “My” to the beginning of the file name. In the above activity, for example, a file called “Sales” is being used for the first time. At the end of this activity, you would save the file as “My sales,” thus leaving the “Sales” file unchanged. If you make a mistake, you can start over using the original “Sales” file.
In some activities, however, it might not be practical to rename the data file. If you want to retry one of these activities, ask your instructor for a fresh copy of the original data file.
[bookmark: _Toc342409984]Topic B: Setting your expectationsIntroduction	vii

Properly setting your expectations is essential to your success. This topic will help you do that by providing:
Prerequisites for this course
A description of the target student
A list of the objectives for the course
A skills assessment for the course
[bookmark: _Toc342409985]Course prerequisites
Before taking this course, you should be familiar with personal computers and the use of a keyboard and a mouse. Furthermore, this course assumes that you’ve completed the following courses or have equivalent experience:
Windows 7: Basic, Windows XP: Basic, or Windows Vista: Basic Target student
This course is for students who have little or no Visio experience. You will get the most out of the course if your goal is to become proficient using Visio to create flow diagrams, basic organization charts, and network diagrams.
[bookmark: _Toc342409986]Course objectives
These overall course objectives will give you an idea about what to expect from the course. It is also possible that they will help you see that this course is not the right one for you. If you think you either lack the prerequisite knowledge or already know most of the subject matter to be covered, you should let your instructor know that you think you are misplaced in the class.
After completing this course, you will know how to:
Navigate in a file, change view settings, identify interface components, use Visio Help; work with windows and stencils; and select, scale, and resize objects.
Draw and reshape objects; work with compound lines; duplicate objects; and align, distribute, group, and rotate objects.
Plan a flowchart; use master shapes; connect shapes in a diagram; work with text; and create a simple organization chart.
Format text and text blocks, control attributes including font size, text color, margins, alignment, and line spacing, apply style themes and effects, and format shapes and lines.
Set file, page, and print properties; use Print Preview; create print headers and footers; print a drawing; work with background pages; use fields to display information; and create hyperlinks.
Create network, rack, and brainstorming diagrams, and import and export data.
Use guides to precisely align and glue shapes, add new connection points to a shape, set properties for shapes, create and apply custom properties, create and run reports, format a report table, and update a report.
[bookmark: _Toc342409987]Skills inventory
Use the following form to gauge your skill level entering the class. For each skill listed, rate your familiarity from 1 to 5, with 5 being the most familiar. This is flot a test. Rather, it is intended to provide you with an idea of where you’re starting from at the beginning of class. If you’re wholly unfamiliar with all the skills, you might not be ready for the class. If you think you already understand all of the skills, you might need to move on to the next course in the series. In either case, you should let your instructor know as soon as possible.

	Skill
	1
	2
	3
	4
	5

	Creating a new file
	
	
	
	
	

	Identifying interface components
	
	
	
	
	

	Using Visio Help
	
	
	
	
	

	Navigating in a Visio drawing
	
	
	
	
	

	Changing View settings
	
	
	
	
	

	Modifying stencils
	
	
	
	
	

	Selecting, scaling, and resizing objects
	
	
	
	
	

	Drawing objects and changing their size
	
	
	
	
	

	Working with compound lines
	
	
	
	
	

	Duplicating objects
	
	
	
	
	

	Aligning, distributing, grouping, and rotating objects
	
	
	
	
	

	Planning a flowchart
	
	
	
	
	

	Using master shapes
	
	
	
	
	

	Connecting shapes in a diagram
	
	
	
	
	

	Working with text
	
	
	
	
	

	Creating an organization chart
	
	
	
	
	

	Formatting text and text blocks
	
	
	
	
	

	Formatting shapes and lines
	
	
	
	
	

	Applying style themes and effects
	
	
	
	
	

	Setting file properties
	
	
	
	
	

	Creating and applying background pages
	
	
	
	
	

	Creating hyperlinks
	
	
	
	
	

	Using Print Preview
	
	
	
	
	

	Creating print headers and footers
	
	
	
	
	

	Printing a diagram
	
	
	
	
	

	Creating network diagrams
	
	
	
	
	

	Creating rack diagrams
	
	
	
	
	

	Creating brainstorming diagrams
	
	
	
	
	

	Importing and exporting XML data
	
	
	
	
	

	Using guides to precisely align and glue shapes
	
	
	
	
	

	Creating new connection points
	
	
	
	
	

	Setting properties for shapes
	
	
	
	
	

	Creating custom properties
	
	
	
	
	

	Creating and modifying reports
	
	
	
	
	


[bookmark: _Toc342409988]Topic C: Re-keying the course
If you have the proper hardware and software, you can re-key this course after class. This section explains what you’ll need in order to do so, and how to do it.
[bookmark: _Toc342409989]Hardware requirements
Your personal computer should have:
A keyboard and a mouse
500 MHz processor (or higher)
At least 256 MB RAM
At least 1.5 GB of available hard disk space
A CD-ROM or DVD drive
An SVGA monitor (1024×768 or higher resolution)
[bookmark: _Toc342409990]Software requirements
You will also need the following software:
Windows 7, Windows XP, or Windows Vista, updated with the most recent service packs
This course was written using Windows 7. If you use another version of Windows, the screens will look different.
Microsoft Visio Professional 2010
Microsoft Excel 2010 or later (If this is not installed, you will not be able to complete activities C-2, C-3, and C-4 in the unit titled “Customization and reporting.”)
If you are using a version of Windows older than Windows 7, install a printer driver. (An actual printer is not required, but if a printer driver is not installed on older versions of Windows such as XP or Vista, activities A-2 and A-3 in the unit titled “Working with pages” might not work as written.)
[bookmark: _Toc342409991]Network requirements
The following network components and connectivity are also required for rekeying this course:
Internet access, for the following purposes:
· Downloading the latest critical updates and service packs
· Downloading the student data files from www.axzopress.com (if necessary)
Setup instructions to re-key the course
Before you re-key the course, you will need to perform the following steps.
Use Windows Update to install all available critical updates and service packs.
If using a flat panel display, we recommend using the panel’s native resolution 
for best results. Color depth/quality should be set to High (24 bit) or higher.
Please note that your display settings or resolution may differ from the author’s, and so your screens might not exactly match the screen shots in this manual.
If necessary, reset any Visio defaults that you have changed. If you do not wish to reset the defaults, you can still re-key the course, but some activities might not work exactly as documented.
If you have the data disc that came with this manual, locate the Student Data folder on it and copy it to the desktop of your computer.
If you don’t have the data disc, you can download the student data files for the course:
1. Connect to www.axzopress.com.
Under Downloads, click Instructor-Led Training.
Browse the subject categories to locate your course. Then click the course title to display a list of available downloads. (You can also access these downloads through our Catalog listings.)
Click the link(s) for downloading the student data files.
Create a folder named Student Data on the desktop of your computer.
Double-click the downloaded zip file(s) and drag the contents into the Student Data folder.
[bookmark: _Toc342409992]Unit 1 - Getting started
Complete this unit and you’ll know how to:
1. Identify components of the Visio 2010 interface, navigate a Visio drawing, and get help using Visio. 
1. Manipulate windows and stencils, and select, scale, and resize objects.
[bookmark: _Toc342409993]Topic A: The Visio 2010 interface
[bookmark: _Toc342409994]Explanation
$$With Visio 2010, you can create a variety of complex diagrams that are dynamic and data-driven. For example, you can create organizational charts, floor plans, circuit diagrams, network diagrams, and Web site maps, to name just a few. After you create a diagram in Visio, you can use it in other Office applications, such as Word, Excel, and PowerPoint. Before you begin creating graphics in Visio, you should become familiar with the Visio interface and tools.
[bookmark: _Toc342409995]The Fluent interface and Ribbon
Visio 2010 uses Microsoft’s “Fluent interface,” which makes it faster and easier for you to find the commands you need. The Ribbon is the main feature of the interface and shows the most frequently used commands rather than hiding them inside menus.
When you click a Ribbon tab (such as Home, Insert, or Design), the Ribbon displays separate groups of related commands. For example, Exhibit 1-1 points to the Tools and Shape groups on the Home tab. Some tools are buttons you click to take an immediate action, while others expand to display menus, lists, or galleries with more options. (A gallery is a collection of style options represented graphically to provide a simple preview.) While most of Visio’s interface components are unique to Visio, several features and commands are common to all Microsoft Office 2010 applications.
$$[image: ]Ribbon tabs Shapes window     Ribbon Drawing window	Ribbon groups


Exhibit 1-1: The Visio 2010 interface
Components of the interface
The Visio workspace is divided into two main sections, the Shapes window and the Drawing area or “page.” The elements of the workspace are described in the following table.
	Item
	Description

	Ribbon
	Contains Visio’s tools and commands, which are organized in logical groups and divided across separate tabs, which change based on the current file or template in use

	Ribbon tabs
	Each tab displays groups of related commands. Visio’s main Ribbon tabs are File, Home, Insert, Design, Data, Review, and View. Some Ribbon tabs are contextual— they appear only if the object they control is inserted or selected.

	Ribbon groups
	Commands on each Ribbon tab are organized logically in groups. For example, commands for formatting text are arranged together in the Font and Paragraph groups on the Home tab



$$Shapes window displays the stencils associated with the current file or template. Stencils are collections of related shapes. Each stencil is specialized for a specific type of drawing. You can open multiple stencils with each drawing.
	Drawing window
	The area of the interface that displays the page you’re working on. The top and left sides of the Drawing $$window show rulers that display measurement units to help you precisely position objects in a drawing. $$Rulers also provide access to guides that help you align objects and shapes while drawing. $$Page tabs at the bottom of the Drawing window allow you to switch between pages in a multi-page drawing. To switch to a different page, click one of the tabs. You can also use the navigation buttons to the left to scroll page tabs.


$$DD : You are not able to select more than 1 tab at each.
$$Show : [image: ]
Visio also incorporates standard Office application components such as the title bar, which displays the name of the current document at the top of the window, and the status bar, which is located at the bottom of the application window and displays the page number, View commands, and the Zoom controls.
Minimizing the ribbon
While the Ribbon makes it easy to access frequently used commands, it also takes up a lot of space on the screen. You might prefer to minimize the Ribbon at times to have more screen space in which to work. You can minimize the Ribbon either by clicking the Minimize the Ribbon button or by double-clicking the active tab. The Minimize the Ribbon button is the caret-shaped button at the right end of the Ribbon.
When the Ribbon is minimized, you can click a tab to temporarily show it to access a command. The Ribbon will be displayed until you click a command or click elsewhere in the window. Then it will be hidden again. To expand the Ribbon and keep it expanded, click the Expand the Ribbon button (the downward-pointing caret) or double-click a tab.
The Quick Access toolbar$$
The Quick Access toolbar, provides a convenient location for frequently used commands. By default, the Save, Undo, and Repeat/Redo commands are available. You can personalize the Quick Access toolbar by adding commands that you use frequently. The Quick Access toolbar is located above the Ribbon by default, but you can display it below the Ribbon. To do so, click the arrow on the right side of the toolbar and choose Show Below the Ribbon from the Quick Access Toolbar menu.	Quick Access					Dialog box
2.	toolbar	launchers

[image: ]




Exhibit 1-2: Additional interface components Dialog box launchers
In some Ribbon groups there are more commands and settings than can be displayed on the Ribbon. Dialog boxes are available to display more options when necessary. To open a dialog box, click the dialog box launcher in the lower-right corner of a Ribbon group, as shown in Exhibit 1-2. In this example, the launchers in both groups open the Text dialog box, with either the Font tab or Paragraph tab active by default.
The Backstage view
The “Backstage view” displays commonly used file-management commands, such as Open, Save As, and Print. This is where you manage your documents and related data. To open the Backstage view, click the File tab. In Backstage view, you can also create a file or see a list of recently opened files, manage information about a file, such as permissions and properties, and change application settings.
Visio file types
$$There are three types of Visio files: 
drawings (.vsd files), 
stencils (.vss files)
templates (.vst files). 
Templates contain the associated stencils, page layout, and styles used to format shapes, text, and other drawing objects. You can use one of Visio’s built-in templates, or you can create your own.
By default, the Open dialog box displays only Visio drawing files. To select a different file type, use the File types list, which includes all Visio file types as well as file types from some other applications. When you import a drawing from another application, the file is converted to Visio format.
[bookmark: _Toc342409996]Do it!	A-1: Exploring the Visio 2010 interface
	Here’s how
	Here’s why

	1 Click Start
	(The Start button.) To display the Start menu.  

	Choose All Programs, Microsoft Office, Microsoft Visio 2010
	To start Visio.

	2 Locate the File tab
	The blue File tab is active by default. This displays the Backstage view, which provides options for creating new files and managing documents.

	3 Click Open
	The Open dialog box appears.

	Navigate to the current topic folder
	

	Select Overview.vsd
	

	Click Open
	To open the file.

	4 Locate the title bar
	The title bar shows the name of the open file and the application name.

	5 Locate the Quick Access toolbar
	This area of the interface provides a convenient location for the most frequently used commands. You can customize the commands that appear on the Quick Access toolbar.

	6 Locate the Ribbon
	The Ribbon is divided into tabs. When you open a file, the Home tab is active by default.

	7 Locate the Shapes window
	(The left pane.) This area displays the stencils associated with the current file or template. Stencils are collections of related shapes.

	8 Observe the Home tab
	The Home tab is divided into groups: the Clipboard, Font, Paragraph, Tools, Shape, Arrange, and Editing groups. Each group contains related commands and menus.

	9 Click the Insert tab
	

	In the Illustrations group, point as shown 
	To display its command groups on the Ribbon. 
[image: ]
After a few moments, a ScreenTip appears, describing the functionality of the Picture button. You can point to any command to view information about that command.

	10 Locate the Drawing window
	This area displays the pages that you’ll create and edit. By default, a grid is visible on empty areas of the page. You can use the grid to help you place objects precisely.

	Locate the rulers
	(On the top and left sides of the Drawing window.) The rulers can help you to line up and arrange objects precisely.

	11 Click the Design tab
	To view the design-related commands and options.

	12 In the Page Setup group, click
	(The dialog box launcher is in the lower-right click corner of the Page Setup command group.) To open the Page Setup dialog box. You can use dialog boxes to access additional options.

	Click Cancel
	To close the dialog box.

	13 At the right end of the Ribbon, click
	To minimize the Ribbon, giving you more space to work with your diagrams.

	14 Click
	To expand the Ribbon.

	15 Double-click the Design tab
	To minimize the Ribbon.

	16 Click the Insert tab
	To temporarily expand the Ribbon.

	Click an empty area on the page
	The Ribbon is minimized again. Clicking a tab once does not return the Ribbon to its default state.

	17 Double-click the Home tab
	To expand the Ribbon.  Click an empty area on the page The Ribbon is not minimized—double-clicking a tab when the Ribbon is minimized returns the Ribbon to its default state.



$$Visio is a vector-based illustration tool. Vector images are composed of mathematically computed lines, resulting in sharp images that are not resolution-dependent (as bitmap images are). Bitmap images are composed of dots called pixels, the smallest unit of color that a monitor can display. The number of pixels per square inch determines the resolution, or fineness of detail. The more pixels per inch an image has, the greater its resolution. High-resolution images are sharp but can result in large files. Although Visio is a vector-based application, you can include bitmap images, such as photographs, in your illustrations.
Shapes, stencils, and styles
$$The basic drawing object in a Visio file is a shape. Shapes are grouped together on stencils. Stencils hold the basic master shapes, or building blocks, used for specific types of drawings. Stencils are designated by the type of drawing they’re best suited for. For example, for flowchart diagramming, you use the flowchart stencil.
$$In addition, you can use drawing tools to create basic objects such as lines and boxes. By drawing and editing basic shapes, you can create different elements that you can combine with other objects to create complex drawings.
By modifying object attributes, called styles, you can produce a variety of design features and effects. For example, you can apply colors, shadows, fill patterns, line properties, and many other formats.
Navigation and viewing tools
As you work, you’ll likely need to open or close certain windows, or zoom in and out of certain areas of a drawing to see things more clearly. Visio provides several tools that you can use to view and navigate a drawing.
$$The View tab
You can quickly change view settings by using the commands and options on the View tab. For example, you can show or hide various elements of the work area, enable or disable visual aids, and zoom in and out of a particular region.
$$Zooming
While working on a drawing, you might want to zoom in to see certain areas more clearly. One way to zoom in and out is to use the Zoom dialog box. On the View tab, click the Zoom button to open the Zoom dialog box, which contains several magnification levels to choose from, as shown in Exhibit 1-3. You can also select Percentage and then enter your own zoom level. Another way to open the Zoom dialog box is to click the percentage value on the right side of the status bar.
[image: ]
Exhibit 1-3: The Zoom dialog box Zooming with the keyboard
You can also zoom in and out of drawings quickly by using combined keyboard commands and mouse clicks. To zoom in, press Ctrl+Shift and click the drawing. To zoom out, press Ctrl+Shift and right-click the drawing.
$$The Zoom slider
Another option for adjusting the display magnification is the Zoom slider, shown in Exhibit 1-4. The Zoom slider is located on the right side of the status bar, at the bottom of the Visio window. You can click the minus sign to zoom out or the plus sign to zoom in. Or, you can drag the slider to the left or right to set the desired zoom level. The current zoom level is displayed to the left of the Zoom slider.
Zoom level 	Zoom slider		Pan & Zoom
[image: ]
Exhibit 1-4: The Zoom slider Pan & Zoom
You can also use the Pan & Zoom tool to navigate a drawing. When you click the Pan & Zoom Window button, shown in Exhibit 1-4, a small window opens, showing a thumbnail of the current drawing. A red box represents the area on the drawing currently in view in the Drawing window. You can click anywhere on the thumbnail to move the focus to that region, or drag from inside the red box to move the focus. This is called panning. You can also use the keyboard arrow keys to control panning in the Pan & Zoom window.
You can drag on the thumbnail to define a new panning region (red box). To close the Pan & Zoom window, click the X in the lower-right corner of the Pan & Zoom window.
[bookmark: _Toc342409997]Do it!		A-2: Changing view settings
	Here’s how
	Here’s why

	Click the View tab
	To display the View commands and options.

	In the Show group, uncheck Ruler
	To turn off the rulers. The rulers can help you to arrange items precisely.

	Uncheck Grid
	To turn off the grid display on empty areas of the page. The grid is another visual aid to help to you place and arrange items precisely.

	2 Turn the ruler and grid back on
	

	3 Click Zoom
	To open the Zoom dialog box.

	Select 100% and click <OK>
	

	
	 To view the page at actual size.

	4 In the status bar, click 100% 
	To open the Zoom dialog box again. (The statusbar displays the current zoom level.)

	Select Percentage 
	You’ll specify a magnification value that is not a default option in the list.

	Type 67 and press Enter 
	 To set the zoom level to 67%.

	5 Press and hold Ctrl + Shift 
	 The mouse pointer changes to a magnifying glass with a plus sign in the middle.

	Click the yellow diamond shape three times
	 [image: ]
(While continuing to hold Ctrl+Shift.) To zoom in on the diamond shape.

	What is the current zoom level?
	

	6 $$Press and hold Control + shift 
	

	Using the right mouse button, drag the pointer across the page
	(While continuing to hold Ctrl+Shift and the right mouse button.) The pointer changes to a small hand and drags the page around the drawing area. You might prefer this method to using the horizontal and vertical scroll bars.

	7 Right-click an area of the page
Release [CTRL) + [SHIFT)
	(While continuing to hold Ctrl+Shift.) To zoom three times out.

	8 On the Status bar, click a few	 times
	To zoom out. 

	9 Drag the slider to the right, as shown 
	[image: ]
To zoom in

	10 On the status bar, click [image: ]
	(The Pan & Zoom Window button.) The Pan & Zoom window opens in the lower-right corner. A red rectangle shows the area currently visible in the Drawing window.

	From inside the red box, drag to another location in the thumbnail
	 To pan to that region of the drawing.

	$$Click any shape in the thumbnail outside of the red box The red box moves to that location, bringing the shape into view in the Drawing window.
	

	11 Close the Pan & Zoom window
	Click the “X” in the lower-right corner.

	12 Click [image: ]
	(To the right of the Zoom slider.) To fit the page into the current window size.



[bookmark: _Toc342409998]Page navigationGetting started	1–11

$$Drawings may contain more than one page. To navigate through a multi-page drawing, click the page tabs at the bottom of the Drawing window. You can also cycle through drawing pages by pressing Ctrl+Page Up and Ctrl+Page Down.
If your file contains many pages, some of the page tabs might be hidden, and you’ll need to scroll to view them. You can navigate page tabs by using the controls on the left side, shown in Exhibit 1-5. Using these controls brings only page tabs into view, not actual drawing pages.
Page tab	Page tabs
controls
[image: ]
Exhibit 1-5: Page tabs and controls 
$$Renaming pages
By default, pages are numbered (Page-1, Page-2, Page-3, etc.), but you can rename them more descriptively. Renaming pages is useful if the drawing has many pages, because you can locate the exact chart or diagram you want based on the page title instead of cycling through to find the one you want.
To rename a page, double-click the page tab, type the new name, and press Enter. Or, you can right-click the page tab, choose Rename from the menu, type the new name, and press Enter.
[bookmark: _Toc342409999]Visio Help
As you begin to work with Visio on your own, you’ll likely encounter windows or stencil objects that you aren’t familiar with. Visio provides a comprehensive Help system to support you as you work. There are several ways you can get information about Visio components and techniques.
The Help window
The Visio Help window, shown in Exhibit 1-6, provides assistance and information on practically all Visio-related topics. You can use it to search for specific content by using keywords or by selecting from a list of topics in the table of contents.
To open the Visio Help window, click the question-mark icon in the upper-right corner of the Visio window, or press F1. You can also open the Help window by clicking the “More...” links in the ScreenTips.
[image: ]
Exhibit 1-6: The Visio Help window with an expanded table of contents ScreenTips
ScreenTips are another way you can get more information about components of the Visio environment. As shown in Exhibit 1-7, ScreenTips appear when you point to Ribbon tools or stencil shapes.
[image: ]
Exhibit 1-7: An example of a ScreenTipGetting started	1–13

[bookmark: _Toc342410000]Topic B: Windows, stencils, and objects
As you work on a diagram, you might want to change the default layout of the Shapes window or individual stencils. You can customize many items of the workspace to suit your preferences.
[bookmark: _Toc342410001]Docked windows vs. anchored windows
You can either dock windows or anchor them. A docked window is attached to the left or right side of the application window, and it stretches across the entire height of the screen, regardless of its content. The default position of the Shapes window is an example of a docked window.
To dock a window, drag it to the left or right side of the application window until it snaps into place.
An anchored window is attached to an edge of the Drawing window, and you can manually change its width and height. You can also temporarily hide or expand anchored windows by clicking the AutoHide button. With AutoHide activated, the window’s contents are shown only when you point to the window. When you point outside the window, it collapses automatically.
To anchor a window, slowly drag from its title bar toward an edge of the Drawing window until it snaps into place.
[bookmark: _Toc342410002]Floating windows $$(Try with shapes only)
A floating window is neither docked nor anchored, but floats independently wherever you want it on screen. For example, Exhibit 1-8 shows the Basic Shapes stencil as a floating window. You can manually resize a floating window by pointing to any of its four edges and then dragging.
[image: ]
Exhibit 1-8: A floating stencil window
To float a docked or anchored window, drag its title bar toward the center of the Drawing window. You can also right-click the title bar and choose Float Window. After you have floated a window, you can drag it anywhere in the work area. However, if you drag too close to an edge of the work area, the window will automatically snap to that edge and will be either anchored or docked. You can prevent this by holding down the Ctrl key as you drag. To dock a floating window, right-click its title bar and choose Dock Window.
[bookmark: _Toc342410003]Working with stencilsGetting started	1–15

$$Show the stencils place and numbers of !(Find *.VSS) [image: ]
$$Close manually a stencil
$$Reopen-it manually
$$ Saving a document with personal stencil
C:\Program Files (x86)\Microsoft Office\Office14\Visio Content\1033 
$$When you create a drawing based on a template, only the stencils associated with the template are shown by default. You can open new stencils by choosing them from the More Shapes menu. By default, open stencils are grouped together in the Shapes window, and only one set of stencil shapes is visible at a time. To switch stencils, click the title bar of the stencil you want to view. To close a stencil, right-click its title bar and choose Close.
You can arrange stencil windows using the same techniques mentioned earlier, except there’s no Dock Window command. To dock a floating stencil, drag it onto the Shapes window.
[bookmark: _Toc342410004]Changing the stencil display
$$You can view additional information on individual stencil shapes by right-clicking a stencil’s title bar and choosing an option from the View submenu. The options are Icons and Names (the default option), Names Under Icons, Icons Only, Names Only, and Icons and Details.
[bookmark: _Toc342410005]Editing objects
In Visio, objects are shapes, connector lines, or any other items in a drawing. You need to select objects before you can change them. For example, after you select an object or group of objects, you can move or resize them.
Selection methods
To select an object, first verify that the Pointer tool is selected and then click the object you want to select. (The Pointer tool is on the Home tab, in the Tools group.) When you select an object, a selection box appears around it, as shown in Exhibit 1-9. The selection box has eight selection handles. You can use the handles to resize or rotate the object.
$$Selection box - Selection handles

[image: ]
1. Exhibit 1-9: A selected object
At times you’ll need to select more than one object. For example, you might want to move objects simultaneously or change their color. Instead of selecting and changing each object individually, you can select them all and make your changes to all of them at the same time.
$$You can select multiple objects by:
Holding the Shift key as you click the objects 
Dragging a marquee around the objects
You can also use the options in the Select menu, in the Editing group on the Home tab.
$$Click Select and choose Select All. This selects all objects on the page.
$$Click Select and choose Select by Type. Then select the desired options and click OK.
$$Click Select and choose Lasso Select. Then draw a freeform shape around the objects.
$$Moving an object Alone + Shift !
After you select one or more objects, you can drag them to a new location in the drawing. When you want to move an object, remember to point to the middle of the object. Otherwise, if the pointer gets too close to a selection handle, you might accidentally resize the object instead of moving it. If you inadvertently resize or move an object, press Ctrl+Z to undo the change, or click the Undo button on the Quick Access toolbar.
[bookmark: _Toc342410006]$$ Saving a Visio fileGetting started	1–19

You should save your work regularly. To save a file, you have two options: Save and Save As. When you use the Save command, Visio updates the open file with its current name in its current location. You can use the Save button on the Quick Access toolbar or press Ctrl+S.
Use the Save As command to save the active file with a different name and/or in a different location. (This creates a copy of the file, unless you’re saving it for the first time.) If you’re working on a new drawing that has never been saved, you’ll automatically be prompted to provide a name and location for the file in the Save As dialog box.
[bookmark: _Toc342410007]Scaling and resizing
$$You can scale and resize an object by dragging its selection handles. Scaling maintains the height‑to-width proportions, while resizing changes the size without maintaining the proportions.
Scaling an object $$
To scale an object, select it and point to any corner selection handle until the pointer changes to a double-headed arrow. Then, drag away from the object to increase the size proportionally, or drag toward the center of the object to decrease the size proportionally.
Use corner handles to scale objects

Use center handles to resize objects
[image: ][image: ]$$
Exhibit 1-10: Scaling and resizing an object Resizing an object
Use the center selection handles to resize an object without maintaining its proportions. This is useful if you want to stretch an object or otherwise change one of its proportions. To resize an object, point to any of the center selection handles and drag.
You can also maintain an object’s proportions by holding down the $$Shift key and dragging a center selection handle.
[bookmark: _Toc342410008]Unit 2 Drawing tools
Complete this unit, and you’ll know how to:
Draw and manipulate shapes.
Work with compound lines and use several methods to duplicate objects.
Align, distribute, group, and rotate objects.
[bookmark: _Toc342410009]Topic A: Basic shapes and lines
If the stencils don’t provide all the shapes you need, you can draw your own. Visio provides several tools for drawing shapes and lines.
[bookmark: _Toc342410010]Drawing tools
$$To draw your own shapes, you use the Drawing tools, located in the Tools group on the Home tab. The drawing tools are described in the following table.
	Tool
	Button Use it to...

	Line
	Create single-segmented lines.

	Arc
	Create simple arcs.

	Rectangle
	Draw rectangles and squares. Hold the Shift key while using this tool to create a square.

	Ellipse
	Create ovals and circles. Hold the Shift key while using this tool to create a circle

	Pencil
	Draw lines and arcs without changing tools, and reshape other objects.

	Freeform
	Create multi-segmented curved lines.



To create basic shapes, select the Rectangle, Ellipse, Arc, or Line tool, and then drag on the drawing area. An example is shown in Exhibit 2-1.
	Starting point
	[image: ]
	Drag to create the shape.


Exhibit 2-1: Using a drawing tool to create a basic shape
[bookmark: _Toc342410011]Page navigation
Drawings may contain more than one page. To navigate through a multi-page drawing,
Click the page tabs at the bottom of the Drawing window. You can also cycle through drawing pages by pressing Ctrl+Page Up and Ctrl+Page Down.
If your file contains many pages, some of the page tabs might be hidden, and you’ll need to scroll to view them. You can navigate page tabs by using the controls on the left side, shown in Exhibit 1-5. Using these controls brings only page tabs into view, not actual drawing pages.
Page tab	Page tabs
controls
[image: ]
Exhibit 1-5: Page tabs and controls Renaming pages
By default, pages are numbered (Page-1, Page-2, Page-3, etc.), but you can rename them more descriptively. Renaming pages is useful if the drawing has many pages, because you can locate the exact chart or diagram you want based on the page title instead of cycling through to find the one you want.
To rename a page, double-click the page tab, type the new name, and press Enter. Or, you can right-click the page tab, choose Rename from the menu, type the new name, and press Enter.
[bookmark: _Toc342410012]Visio Help
As you begin to work with Visio on your own, you’ll likely encounter windows or stencil objects that you aren’t familiar with. Visio provides a comprehensive Help system to support you as you work. There are several ways you can get information about Visio components and techniques.
The Help window
The Visio Help window, shown in Exhibit 1-6, provides assistance and information on practically all Visio-related topics. You can use it to search for specific content by using keywords or by selecting from a list of topics in the table of contents.
To open the Visio Help window, click the question-mark icon in the upper-right corner of the Visio window, or press F1. You can also open the Help window by clicking the “More...” links in the ScreenTips.
[image: ]
Exhibit 1-6: The Visio Help window with an expanded table of contents ScreenTips
ScreenTips are another way you can get more information about components of the Visio environment. As shown in Exhibit 1-7, ScreenTips appear when you point to Ribbon tools or stencil shapes.
[image: ]
Exhibit 1-7: An example of a ScreenTipGetting started	1–13

[bookmark: _Toc342410013]Topic B: Windows, stencils, and objects
As you work on a diagram, you might want to change the default layout of the Shapes window or individual stencils. You can customize many items of the workspace to suit your preferences.
[bookmark: _Toc342410014]Docked windows vs. anchored windows
You can either dock windows or anchor them. A docked window is attached to the left or right side of the application window, and it stretches across the entire height of the screen, regardless of its content. The default position of the Shapes window is an example of a docked window.
To dock a window, drag it to the left or right side of the application window until it snaps into place.
An anchored window is attached to an edge of the Drawing window, and you can manually change its width and height. You can also temporarily hide or expand anchored windows by clicking the AutoHide button. With AutoHide activated, the window’s contents are shown only when you point to the window. When you point outside the window, it collapses automatically.
To anchor a window, slowly drag from its title bar toward an edge of the Drawing window until it snaps into place.
Floating windows
A floating window is neither docked nor anchored, but floats independently wherever you want it on screen. For example, Exhibit 1-8 shows the Basic Shapes stencil as a floating window. You can manually resize a floating window by pointing to any of its four edges and then dragging.
[image: ]
Exhibit 1-8: A floating stencil window
To float a docked or anchored window, drag its title bar toward the center of the Drawing window. You can also right-click the title bar and choose Float Window. After you have floated a window, you can drag it anywhere in the work area. However, if you drag too close to an edge of the work area, the window will automatically snap to that edge and will be either anchored or docked. You can prevent this by holding down the Ctrl key as you drag. To dock a floating window, right-click its title bar and choose Dock Window.
Working with stencils
When you create a drawing based on a template, only the stencils associated with the template are shown by default. You can open new stencils by choosing them from the More Shapes menu. By default, open stencils are grouped together in the Shapes window, and only one set of stencil shapes is visible at a time. To switch stencils, click the title bar of the stencil you want to view. To close a stencil, right-click its title bar and choose Close.
You can arrange stencil windows using the same techniques mentioned earlier, except there’s no Dock Window command. To dock a floating stencil, drag it onto the Shapes window.
Changing the stencil display
You can view additional information on individual stencil shapes by right-clicking a stencil’s title bar and choosing an option from the View submenu. The options are Icons and Names (the default option), Names Under Icons, Icons Only, Names Only, and Icons and Details.
[bookmark: _Toc342410015]Editing objects
In Visio, objects are shapes, connector lines, or any other items in a drawing. You need to select objects before you can change them. For example, after you select an object or group of objects, you can move or resize them.
Selection methods
To select an object, first verify that the Pointer tool is selected and then click the object you want to select. (The Pointer tool is on the Home tab, in the Tools group.) When you select an object, a selection box appears around it, as shown in Exhibit 1-9. The selection box has eight selection handles. You can use the handles to resize or rotate the object.
[image: ]Selection box

 				Selection handles


Exhibit 1-9: A selected object
At times you’ll need to select more than one object. For example, you might want to move objects simultaneously or change their color. Instead of selecting and changing each object individually, you can select them all and make your changes to all of them at the same time.
You can select multiple objects by:
Holding the Shift key as you click the objects 
Dragging a marquee around the objects
You can also use the options in the Select menu, in the Editing group on the Home tab. Click Select and choose 
· Select All. This selects all objects on the page.
· Click Select and choose Select by Type. Then select the desired options and click OK.
· Click Select and choose Lasso Select. Then draw a freeform shape around the objects.
[bookmark: _Toc342410016]Moving an object
After you select one or more objects, you can drag them to a new location in the drawing. When you want to move an object, remember to point to the middle of the object. Otherwise, if the pointer gets too close to a selection handle, you might accidentally resize the object instead of moving it. If you inadvertently resize or move an object, press Ctrl+Z to undo the change, or click the Undo button on the Quick Access toolbar.
[bookmark: _Toc342410017]Saving a Visio fileGetting started	1–19

You should save your work regularly. To save a file, you have two options: Save and Save As. When you use the Save command, Visio updates the open file with its current name in its current location. You can use the Save button on the Quick Access toolbar or press Ctrl+S.
Use the Save As command to save the active file with a different name and/or in a different location. (This creates a copy of the file, unless you’re saving it for the first time.) If you’re working on a new drawing that has never been saved, you’ll automatically be prompted to provide a name and location for the file in the Save As dialog box.
[bookmark: _Toc342410018]Lines and arcs$$Drawing tools	2–5

You can create and edit lines and arcs by using the Line and Arc tools. To draw straight lines, select the Line tool and drag on the page. By default, Visio is configured to snap lines to 45-degree increments. When the line is at a 45-degree angle, a gray guideline appears and extends across the page. To constrain lines to 45-degree increments only, press and hold the Shift key as you drag.
You can draw curved lines with the Arc tool. The direction of the arc depends on the direction you drag, as illustrated in Exhibit 2-2. For example, if you drag up and to the right, the arc will bend up and to the right. If you drag slightly down, and then up and to the right, the arc will bend in the opposite direction.
[image: ]
Exhibit 2-2: Drawing curved lines with the Arc tool
[bookmark: _Toc342410019]Reshaping an arc
You can fine-tune an arc by reshaping and rotating it. If you select an arc with the Pointer tool, a control handle appears in the middle of the arc, in addition to endpoints at both ends. To change the curve of the arc, drag the center control handle, as shown in Exhibit 2-3.
$$Drag the center control handle to reshape the arc’s curve
[image: ]
Exhibit 2-3: Reshaping an arc Reshaping with the Pencil tool
$$You can also reshape arcs by using the Pencil tool. When you select the Pencil tool, the control handle in the center of the arc changes from a square to a circle, and eccentricity handles extend from it, as shown in Exhibit 2-4. You can drag the eccentricity handles to reshape the arc’s curve.
Eccentricity handles
 	[image: ]
Exhibit 2-4: Adjusting an arc with the Pencil tool
[bookmark: _Toc342410020]Topic B: Compound lines
Simple lines consist of a single line segment. Compound lines consist of multiple line segments. You can create two types of compound lines in Visio. You can create a freeform line with the Freeform tool, or you can connect line segments by using the Line, Arc, and Pencil tools.
[bookmark: _Toc342410021]Freeform lines$$
If you want to create a free-flowing compound line, use the Freeform tool. This tool creates exactly what you draw as you drag the pointer, similar to the way you draw with a pencil and paper. When you drag with the tool, Visio automatically creates multiple control points as needed to shape the curves, as shown in Exhibit 2-5.
[image: ]Control points

Exhibit 2-5: A freeform line
[bookmark: _Toc342410022]Using the Line and Arc tools to create compound lines
Another way you can create compound lines is to use the Line and Arc tools. Select the tool you want and then create each segment in succession. To begin a new segment, point to the endpoint of the previous segment and then drag. When you use this technique, the segments are connected by vertex points, the diamond-shaped points shown in Exhibit 2-6.
[image: ]
Vertex points
Exhibit 2-6: A compound line drawn with the Line and Arc tools
Using the Pencil tool to create compound lines
You can also create compound lines with the Pencil tool, which can function as both the Line and Arc tools combined. The type of line segment you create is determined by the way you drag with the tool. Drag in a straight line to create straight line segments, and drag in the shape of an arc to create curved segments.
Adjusting compound linesDrawing tools	2–15

You can adjust compound lines by manipulating the control and vertex points. If you created a freeform line, you can make adjustments by moving the control points with either the Pointer tool or the Pencil tool. If you created a compound line with the Line, Arc, or Pencil tools, you can move control points as well as vertex points.
In both types of compound lines, you can convert control points to vertex points, and you can add vertex points where there previously weren’t any. To do both, you need to use the Pencil tool. To convert a control point to a vertex point, Ctrl+click the control point you want to convert. To add a vertex point, point to a location on a segment where you want to add the point, and then Ctrl+click the segment.
[bookmark: _Toc342410023]Topic C: Editing objectsDrawing tools	2–17

There are many ways you can edit shapes and lines. Some of the common techniques include duplicating, aligning, distributing, grouping, and rotating shapes.
[bookmark: _Toc342410024]Duplicating an object
You can duplicate an object by using several methods. You can use the Copy and Paste commands on the Home tab (or use the keyboard shortcuts Ctrl+C and Ctrl+V). Or, you can hold down the Ctrl key as you drag an object. When you do this, Visio creates a duplicate of the object. You can also select an object and press Ctrl+D.$$
[bookmark: _Toc342410025]Maintain alignment$$ when duplicating
If you duplicate an object by pressing Ctrl as you drag it, you can also use the Shift key to maintain its alignment. Be sure you do not press Shift until after you start dragging; otherwise, the tool will change to the Magnification tool.
[bookmark: _Toc342410026]$$Using the F4 key to duplicate objects
The F4 key functions as a Repeat key. In many cases, it repeats your last action. This can be useful when you’re duplicating an object by dragging because you not only get a duplicate of the object, but you also duplicate the distance you dragged that object.
[bookmark: _Toc342410027]Object alignment
Y$$ou’ll probably spend a lot of time moving and aligning objects in your drawings.
There are many ways to accomplish these actions, but the easiest way to align objects is to use the options in the Position menu. For example, you can select several adjacent objects and then select Align Center from the Position menu to center the objects precisely.
Reference objects $$
When you align objects, the order in which you select them is critical. The first object you select is the reference object: all other objects you select will be aligned to it. When you select multiple objects, the reference object has a thick pink border, while the other selected objects have thin pink borders, as shown in Exhibit 2-7.

[image: ]
Reference object

Exhibit 2-7: A reference object in a group of selected objects Use the Shift key to select multiple objects
Earlier you learned how to select multiple objects by dragging to create a marquee. However, if you want to select specific objects but leave others unselected, you can hold down the Shift key and click the objects you want to select. You can also remove an object from a group of selected objects by Shift+clicking it.
Live preview$$
You can preview the effect of an alignment command by pointing to an option in the Position menu. For example, if you have selected multiple objects, open the Position menu and point to different alignment options; the objects move on the page to show you how that selected command will affect the shapes.
Object distribution
Distributing objects evenly spaces them from either their centers or their edges. The distance between the first and last objects determines the overall distance. All other objects are distributed evenly to fill the space between the first and last objects. You can distribute objects vertically or horizontally.
To distribute objects, open the Position menu, point to Space Shapes, and select an option from the submenu. Or, you can select More Distribute Options to open the Distribute Shapes dialog box. The following table shows the buttons you’ll find in the Distribute Shapes dialog box and describes their function.
Button Function
Top and bottom inside edges are spaced evenly apart.
Top edges of objects are spaced evenly apart. Vertical centers of objects are spaced evenly. Bottom edges are spaced evenly apart. Left and right inside edges are spaced evenly apart. Left edges are spaced evenly apart.
Horizontal centers of objects are spaced evenly apart.
Right edges are spaced evenly apart.
Grouping$$
You can avoid the problem of staggered arrangements by grouping objects before you align or distribute them. Grouping holds objects together and allows them to act as a single object. Then, when you distribute or align the group, all of the objects in the group move together.
To group objects, select the objects you want to group, click Group, and choose Group. To ungroup objects, select the group, click Group, and choose Ungroup. You can also group and ungroup objects by using the keyboard shortcuts Ctrl+G (to group) and Shift+Ctrl+U (to ungroup).
Rotating objects$$Drawing tools	2–25

You rotate objects around a point called the center of rotation by using rotate handles.
When you select an object with the Rotate tool, the center of rotation appears in the middle of the object. In addition, a round Rotate Shape tool appears at the top of the selected object. You can use this tool to rotate the object clockwise or counterclockwise around the center of rotation.
Moving the center of rotation$$
You can move an object’s center of rotation. You might want to do this if you need to rotate one object around another. To move a center of rotation, you drag it to a new location. It’s still associated with the original shape.
[bookmark: _Toc342410028]Unit 3 - Basic diagrams$$3–1

Complete this unit, and you’ll know how to:µµ
Plan a diagram.
Create a basic diagram and insert, connect, and modify shapes.
Insert and format text.
Create and modify organization charts.
[bookmark: _Toc342410029]Topic A: Planning a diagram
With diagrams, you can present complex information graphically. One type of diagram is a flowchart, which typically represents a process. For example, a flowchart could depict the assembly of a motor on an assembly line. Another type of diagram is an organization chart, which shows a company’s structure. Visio provides other types of charts and diagrams you can use to represent a variety of information.
[bookmark: _Toc342410030]Design tips$$
Effective design begins with an audience analysis. Ask yourself these questions to identify and understand your audience:
Who will use this diagram?
Why will they use it?
What information is most important to them?
The answers to these basic questions will help you target the right diagram to the right people. If you have a wide audience, the questions might be harder to answer. No matter who your audience is, it’s typically best to keep the diagram as simple as possible.
Next, consider the design and purpose of your diagram. Will it be distributed online across a company network? Will you be printing the diagram? If so, will you print in color or black and white? If you are printing in color, use highly contrasting colors to make it easy for your audience to read the diagram and distinguish its components.
[bookmark: _Toc342410031]Diagram shapes
Each step, action, or idea in a diagram is represented by a shape. Some shapes are standard across most processes, such as those used in process mapping. If you’re creating a flowchart, your company might have a standardized set of flowchart symbols that you can use as a guide. Visio organizes commonly used shapes in stencils and incorporates these stencils into diagram templates. When you use a Visio template, the stencils most commonly used for that type of diagram are included in the file.
The following guidelines can help you to select the proper shapes for your diagram:
First, check to see if the shape you want to use is a standard shape for a particular action or function. Often the shapes found on the Basic stencil are enough to get started. If they’re not, many other stencils are available.
Don’t try to reinvent the wheel. Research what your company has done in the past, and find out if there are any company standards you should be following.
Choose a graphic whenever you can’t find the right shape. Often, a graphic can effectively convey a simple idea or action. Consider using a universal type of graphic, such as an industry icon.
As you create the diagram, you don’t need it to be perfect. You might find a shape that’s better suited to the idea you want to convey after you’ve created the drawing. You can always go back and replace a shape without rebuilding the entire diagram.
[bookmark: _Toc342410032]Topic B: Creating a basic diagram
Master shapes are the basic building blocks of a Visio diagram. When you begin a diagram, stencils containing specific master shapes are automatically displayed in the Shapes window.
[bookmark: _Toc342410033]Inserting and connecting shapes$$
You can add shapes to a diagram by dragging shapes from the stencils onto the page. Each shape serves a specific purpose and demonstrates a particular process or function in the diagram. For example, decision shapes in flowchart diagrams represent decisions within a flow of events, while process shapes represent specific steps or tasks.
[bookmark: _Toc342410034]AutoConnect$$
You can save time by using AutoConnect to connect shapes as you add them to the page. AutoConnect is optional but active by default in Visio 2010. When you point to a shape, direction handles appear, as shown in Exhibit 3-1.
[image: ]
AutoConnect handles


Exhibit 3-1: AutoConnect handles$$
When you point to any of these handles, a toolbar of shapes is displayed, as shown in Exhibit 3-2. The shapes that are displayed are from the currently selected stencil. You can point to a shape to preview a connection, or click one to add and connect the shape.
[image: ]
Exhibit 3-2: The AutoConnect toolbar
You can also add and connect new shapes by using the following techniques:
Point to a shape on the page and click an AutoConnect handle. When you do, the last shape you selected in the stencil will automatically be added to the drawing and connected to the shape.
$$Drag a shape from the stencil and hold it over an existing shape until the AutoConnect handles appear. Then move the shape over any of the AutoConnect handles and release the mouse button to add and connect it to the shape.
[bookmark: _Toc342410035]Moving and deleting shapesBasic diagrams	3–5

You will likely need to make ongoing adjustments as you work on a diagram. To delete a shape, select it and press delete. To move a shape, drag it to a desired location. When you move a shape, orange guides appear, indicating the alignment and spacing for precise shape placement. If you want to move multiple shapes at once, select them and drag the selection box to the desired location. Moving shapes does not remove their connections to other shapes.
[bookmark: _Toc342410036]Manually connecting shapesBasic diagrams	3–9

After you have added shapes to a drawing, you can connect them to illustrate their relationship or flow. You have already connected shapes by using AutoConnect features. You can also manually connect drawings with the Connector tool.
The Connector tool$$
At times, you’ll probably want to connect shapes that are not next to each other. You can use the Connector tool to connect shapes that are not adjacent. On the Home tab, in the Tools group, select the Connector tool and then drag the pointer from a connection point on one shape to a connection point on another shape. Connect shapes in the direction of the process flow because arrows are automatically added to connecting lines that point in the direction in which the connection is made.
To ensure that your shapes are properly connected, you can attach them at their connection points. When connected properly, the shapes are “glued.” This secures the shapes together so that when a shape is moved, the connection is not broken.
Point-to-point connections$$
When the Connector tool is selected and you point to a shape, the shape’s connection points come into view—the small blue x on each side. When you point to a connection point, it’s highlighted by a red box. You can drag a connector from one shape’s connection point to the connection point of another shape to create a point-to-point connection. With this type of connection, the connector remains “glued” to those connection points even if a shape is moved.
Shape-to-shape connections$$
You can also create a shape-to-shape connection if you want the connector to stay glued to the shape if it’s moved, but not necessarily glued any particular connection point on the shape. To create a shape-to-shape connection, select the Connector tool and drag from the center of a shape to the center of another shape.
Using AutoConnect for adjacent shapes
If two shapes are next to each other, you can quickly connect them by using AutoConnect. With the Pointer tool, simply point to one of the shapes to display the AutoConnect handles. Then click the handle that points to the other shape.
Connector shapes$$
You can use various connector shapes to achieve specific results. For example, if you want to add text to a connector shape you can use large arrows that provide space for text, as shown in Exhibit 3-3. Connector shapes are located on various stencils, but you can view them all at once on the Connectors stencil.
To open the Connectors Stencil, click More Shapes in the Shapes window. Then choose Visio Extras, Connectors.
[image: ]
Exhibit 3-3: An example of alternate connector shapes
[bookmark: _Toc342410037]Topic C: Working with text$$
You can add text to a diagram, format the text, and apply text to shapes and connectors to provide important information and instruction.
[bookmark: _Toc342410038]Text blocks
Unlike in a typical word processor, text in Visio is contained in a text block, a container for the text. When you add text to a drawing, there are two things at work: the text block and the text itself. Each has its own properties and can be formatted separately. You can add text blocks to shapes, connectors, and other objects. Exhibit 3-4 shows an example of text in shapes and connectors.
[image: ]
Exhibit 3-4: Examples of text in objects
Text blocks give you added flexibility in how text is displayed. For example, you can rotate a text block so that the text is diagonal or vertical. You can format a text block independently of the shape that it’s associated with.
[bookmark: _Toc342410039]Editing text$$
If you need to change text after you’ve added it to a drawing, you can return to text mode. Simply select the Text and then click the text you want to edit. When you’re finished editing, press Esc or click outside the text block.
[bookmark: _Toc342410040]Formatting text$$
To format text, select the text block and then use the options in the Font and Paragraph groups to apply the desired formatting. For example, if you want to change the text size, select the text block and select a new font size from the Font Size list in the Font group. To align text in its text block, select the text block and then click an alignment button in the Paragraph group.
You can also format specific sections of text within a text block. For example, you can make a single letter or word larger than other text in a text block, or change the text color or font face. You can also resize a text box as needed by selecting it and then dragging a handle with the Pointer tool.
[bookmark: _Toc342410041]Paragraph textBasic diagrams	3–19

When you need to add a large amount of text, such as a long paragraph, you can select the text tool, click on the page where you want to add the text, and begin typing until you’re finished. The text box will increase in size to accommodate the text that you enter. You can then move and resize the text block as needed by using the Pointer tool.
Or, you can create a large text block first, and then begin typing. In this way, you can control how large the text area will be before you add text. Select the Text tool and drag to draw a text box of the desired size. The insertion point will be placed in the center of the text box automatically so that you can begin typing immediately. Text automatically wraps when it reaches the end of the text block area.
[bookmark: _Toc342410042]Shape text
You can add text to shapes to describe the steps in a diagram or provide other important information. As soon as you add a new shape to a drawing, you can type to add text in the center of the shape. To add text to an existing shape, select the shape with the Pointer tool or the Text tool and then start typing. (You can also double-click a shape with the Pointer tool.) Visio automatically enters text mode and if necessary, zooms in so that you can see the text more easily.
Exhibit 3-5 shows a Decision shape in text mode—the text block becomes visible. When you’re done adding text, you can click away from the shape or press Esc to exit text mode and return to the previous page magnification.
Double-click a	In text mode, the
shape to enter	text block border
text mode	is visible
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Exhibit 3-5: Adding text to a shape
[bookmark: _Toc342410043]Connectors and text
Connectors are also considered shapes. This means you can add text to connectors by using the same methods you use for adding text to shapes. There are advantages to adding text to connectors: The text moves with the connector, and if the connector length is changed, the text is adjusted automatically.
[bookmark: _Toc342410044]Manipulating shape text
Every shape contains a text block area you can move and manipulate by using either the Text tool or the Text Block tool.
The Text tool vs. the Text Block tool$$
Use the Text tool when you want to add or edit text. When you use the Text tool to select a text block, you enter text mode. You can press Esc to exit text mode and select the text block itself. You can then move, resize, or rotate the text block as needed. When you use the Text Block tool, the text block is selected, not the text inside the block. Like the Text tool, you can use the Text Block tool to rotate the text within its shape, and move and resize a text block.
Rotating a text block
You can rotate a text block by selecting it with either the Text tool or the Text Block tool. A round rotation handle appears outside the text block, as shown in Exhibit 3-6. Drag this handle to rotate the text. It’s best to use the Text Block tool when you want to rotate text because you don’t need to exit text mode before you rotate the text. As soon as you click a text block with the Text Block tool, it’s selected and ready to be moved, rotated, or resized.

[image: ]

You can’t rotate text by using the Pointer tool. When you use the Pointer tool to select a shape, the rotation handle rotates the shape, not the contents of the shape.
[image: ]
Rotation handle


 		Exhibit 3-6: A rotation handle

[bookmark: _Toc342410045]Topic D: Organization charts$$
An organization chart depicts the systematic flow of authority and responsibility. You can use these charts to show superior-subordinate relationships, report hierarchies, and inter-department links in an organization. For example, you can use an organization chart to show the hierarchy of your company’s department structure.
[bookmark: _Toc342410046]Creating organization charts
To create an organization chart, you use the Organization Chart template. When you use this template, the Organization Chart stencil opens and the Org Chart tab is added to the Ribbon.$$
To get started with the Organization Chart template, click the File tab, click New, select Organization Chart, and click Create. Then start building the organization chart by dragging shapes from the Organization Chart stencil to the page. Each organization chart shape typically contains the name and title of a particular person in the organization.
Adding multiple shapes
You can add more than one shape of the same type to an organization chart. For example, you might need five Manager shapes under an Executive shape. You can insert all of the Manager shapes at once by dragging the Multiple Shapes shape onto the page$$. This opens the Add Multiple Shapes dialog box, shown in Exhibit 3-7. In this dialog box, enter the number of shapes you want to create, select the shape type, and click OK.
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Exhibit 3-7: The Add Multiple Shapes dialog box Automatic linking
If you want to create a reporting relationship automatically when you add a new organization shape, you can drag the new shape onto the shape that represents the person or position to which it reports.
[image: ]
Modifying layouts$$ (Donne de drôles de résulstats
A layout defines the way in which shapes are arranged. You might want to change the layout of the shapes to change the hierarchy in an organization chart. The options on the Org Chart tab provide various layout styles, such as horizontal and vertical layouts. Changing the layout of a superior shape changes the layout of all subordinate shapes.
[bookmark: _Toc342410047]Unit summary: Basic diagramsBasic diagrams	3–31

[bookmark: _Toc342410048]Topic A
In this topic, you learned how to plan a basic flowchart. You also learned some tips for using flowchart shapes.
[bookmark: _Toc342410049]Topic B
In this topic, you learned how to create a basic diagram. You learned how to insert shapes by dragging from stencils and by using AutoConnect. Then you learned how to connect and move shapes, and apply different connector types.
[bookmark: _Toc342410050]Topic C
In this topic, you learned how to add text to a drawing and format text. You learned how to apply text to a page, and to individual shapes and connectors. You also learned how to rotate text blocks.
[bookmark: _Toc342410051]Topic D
In this topic, you learned how to create and modify an organization chart.
[bookmark: _Toc342410052]Unit 4 - Formatting drawings
Complete this unit and you’ll know how to:
Format text and text blocks, and apply themes and effects.
Format shapes and lines, create a shadow effect, and use the Format Painter.
[bookmark: _Toc342410053]Topic A: Formatting text
A Visio drawing has three basic elements: shapes, lines, and text. You can format each of these elements to make your diagrams appealing and impactful. For example, you can apply different font faces, alignments, colors, shadows, and line properties.
To format the elements of a drawing, you can use the tools in the Font, Paragraph, and Shape groups on the Home tab, or you can use the Text dialog box.
[bookmark: _Toc342410054]Basic text formatting
To apply basic text formatting such as bold and italic, or change fonts, font sizes, and text color, you can use the commands in the Font group on the Home tab.
You can select a text block to apply formatting to the entire block of text, or you can select and format individual letters or words. To format specific letters or words, double-click the text to enter text mode, and then select the letters or words that you want to format.
[bookmark: _Toc342410055]The Text dialog box$$
[image: ]
You can also click the dialog box launcher in the Font or Paragraph groups to open the Text dialog box, shown in Exhibit 4-1. With this dialog box you can apply additional formatting options that aren’t available by default on the Ribbon, such as transparency, spacing, margins, and background color.
[image: ]
Exhibit 4-1: The Text dialog box with the Font tab active
The Text dialog box contains six tabs. Choose the desired options from each tab and then click Apply. When you’re finished, click OK to close the dialog box. The tabs and their functions are described in the following table.
	Tab
	Use it to...

	Font
	Change font styles, such as font face, size, style, color, casing, and transparency.

	Character
	Set character spacing and scaling.

	Paragraph
	Set paragraph alignment, spacing, and indentation.

	Text Block
	Set margins, alignment, background color, and background transparency.

	Tabs
	Define the position and alignment of tab stops in text blocks.

	Bullets
	Select bullet styles and related options.


[bookmark: _Toc342410056]Text block formatting
As mentioned earlier, you can format text blocks by using the Text Block tab in the Text dialog box. The following table describes the options on the Text Block tab.
	Option
	Used to...

	Alignment
	Position text vertically within the text box. The options are top, middle, and bottom.

	Margins
	Specify the distance between the text and each of the four sides of the text box. This option is useful if you have visible borders on a text box and you want to ensure that the text is sufficiently offset from the edges of the text box.

	Text background
	But only the text background. You can also control the transparency level of the background color by dragging the Transparency slider.


[bookmark: _Toc342410057]Paragraph formatting
On the Paragraph tab of the Text dialog box, you can control horizontal alignment, indents, and spacing. If you select the text box, the formatting you apply affects all the text in that text block. You can also select only certain paragraphs in a text block and then open the Text dialog box to format only the selected paragraphs. The following table describes the formatting options on the Paragraph tab.
	Option
	Used to...

	Alignment
	Align the selected paragraphs horizontally. The options are left, right, centered, and justified.

	Indentation
	Set paragraph indentation. You can indent from the left or the right margin, or only the first line of a paragraph.

	Spacing
	Specify the gap between paragraphs.


[bookmark: _Toc342410058]Themes and effects$$
Themes are predefined sets of colors and styles that you can quickly apply to a drawing.  Each theme consists of a color scheme and styles for fonts, shadows, and connectors. To apply a theme, click the Design tab and then point to a theme in the Themes group. Live Preview shows you the effect the theme will have on your drawing. Click a theme to apply it. Or, click the downward-pointing arrow at the end of the Themes group to open the Themes gallery, which displays all available pre-configured themes, as shown in Exhibit 4-2.
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Exhibit 4-2: The Themes Gallery The Effects list
In addition to the pre-built themes in the Themes gallery, you can use the options in the Effects list to quickly apply eye-catching effects and styles. Pre-built effects will override any existing line, connector, text, and shadow styles.
[bookmark: _Toc342410059]Topic B: Formatting shapes and lines$$
In addition to the pre-built formats available in the Themes gallery, you can create your own shape, line, and connector styles by using the tools in the Shape group on the Home tab. You can also use the commands on the Design tab to apply colors and effects, and customize the background and layout.
[bookmark: _Toc342410060]The Fill, Line, and Shadow tools
When applying colors, each shape has a separate line and fill. The line color is the border around the shape; you can also customize the line style and thickness. The fill color is the shape’s background color. If your shape contains text, it’s important that the text color and the fill color have sufficient contrast so that the text is easy to read and does not strain the eyes.
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Exhibit 4-3: The Fill, Line, and Shadow tools, in the Shape group on the Home tab
You can use the Line dialog box, shown in Exhibit 4-4, to customize the appearance of a selected line. For example, you can apply rounded corners, set dashed or dotted lines, and control the line fill transparency. To open the Line dialog box, open the Line list and choose Line Options.
[image: ]
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Exhibit 4-4: The Line dialog box
[bookmark: _Toc342410061]The Shadow dialog box
You can use the Shadow dialog box to create a custom shadow effect. For example, you can control the shadow color, transparency, and angle. To open the Shadow dialog box, click Shadow and choose Shadow Options.
[image: ]
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Exhibit 4-5: The Shadow dialog box
[bookmark: _Toc342410062]The Format Painter$$
After you have formatted a shape, you might want to apply the same styles to other shapes in the drawing. You can do this by using the Format Painter, which applies the formatting attributes of one shape to one or more other shapes. To use the Format Painter, first select the shape that contains the formatting attributes you want to copy, and then click the Format Painter button, located in the Clipboard group on the Home tab. Then, click another shape in the drawing to apply the same formatting.
If you want to format multiple shapes, double-click the Format Painter button. This prevents Visio from switching back to the previous tool after you format a shape. To deselect the Format Painter, press Esc.
[bookmark: _Toc342410063]Unit 5 - Working with pages$$
Complete this unit and you’ll know how to:
Set file, page, and print properties, use Print Preview, create headers and footers, and print a diagram.
Create and apply background pages, use fields to display information, and add a graphic to a page.
Create hyperlinks to internal detail pages, external files, multiple files, and specific locations in a file.
[bookmark: _Toc342410064]Topic A: File and print properties
When you create a diagram, you might want to add important information about the file. For example, you might want to put your name and company name on the file, the manager for the project, and a brief title or description. In addition, you should prepare your diagram to print successfully, which entails checking and modifying page and printer properties.
[bookmark: _Toc342410065]Viewing and setting file properties
To view and set properties for a file, click the File tab to open the Backstage view. Then click Info to view information about the file. As shown in Exhibit 5-1, a thumbnail preview of the page is shown, followed by various properties such as file size, the company name, the file’s title and subject matter, and the people working on the file. To specify a property, click the prompt to the right of the property and enter a value.
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Exhibit 5-1: File properties in the Info category of the File tab
[bookmark: _Toc342410066]Page and print settings$$
It’s important to consider the page size and orientation. When printing a diagram, you’ll want to choose a page orientation and size that best suits the size or layout of the diagram. You can use the commands in the Page Setup group on the Design tab, and the Page Setup dialog box, to make sure that the printer paper size is optimized for the drawing page you want to print. If the drawing extends beyond the printer paper size, content will be cut off and printed on a separate page.
Page orientation
The page orientation defines how the drawing will be printed on the page. The options are Portrait (210 x 297) or Landscape (297 x 210). For example, if your diagram is wider than it is long, you can change its orientation to Landscape so that as much content as possible can be printed on a page. The default orientation depends on the template in use. To change the page orientation, click the Design tab, click the Orientation button in the Page Setup group, and select either Portrait or Landscape.
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Exhibit 5-2: The Page Setup command group on the Design tab The Auto Size feature
With the Auto Size feature enabled, the page expands if you add or move content beyond the current page boundaries, which can be helpful when you’re working with a large diagram. This feature is on by default. To turn it off, click the Auto Size button in the Page Setup group on the Design tab, shown in Exhibit 5-2.
The Page Setup dialog box$$
You can use the Page Setup dialog box to control page size and printer settings. In many templates, the option “Let Visio expand the page as needed” is selected by default, as shown in Exhibit 5-3. This is the Auto Size feature. You can disable this by selecting Pre-defined size and then selecting a page size from the lists below it. [image: ]
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Exhibit 5-3: The Page Setup dialog box with the Page Size tab activeWorking with pages	5–5

The Page Setup dialog box contains six tabs, each described in the following table.
	Tab
	Description

	Print Setup
	Contains settings for the current printer. The Preview window shows the orientation of the paper against the drawing page.

	Page Size
	Contains size and orientation settings for the drawing page. You can define the page size for each page in a drawing. The Preview window shows the orientation of the paper against the drawing page.

	Drawing Scale
	Defines a scale for the drawing. This is helpful for floor plans and other architectural drawings.

	Page Properties
	Use this tab to specify a name for the page, set the desired measurement units, and assign a background page.

	Layout and Routing.
	Use this tab to define how shapes and lines will appear in print

	Shadows
	Use this tab to define shadow settings for a page.


[bookmark: _Toc342410067]Printer paper size
You can change the printer paper size by using the Size options in the Page Setup command group. Click the Size button and select a page size. Or, open the Page Setup dialog box, click the Print Setup tab, and select a paper size from the list.
[bookmark: _Toc342410068]Print Preview$$
You can use Print Preview to see how a page will look before you print it. You can also use Print Preview to add headers and/or footers. To open Print Preview, click the File tab and select the Print category. Then click Print Preview. The application window changes to show only the File tab and a new Print Preview tab, which contains several print options and controls, as shown in Exhibit 5-4.
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Exhibit 5-4: The Print Preview window Headers and footers
You can add headers and footers to your printed pages. Headers appear at the top of each page, and footers appear at the bottom of each page. To add page headers and/or footers in Print Preview, click the Header & Footer button to open the Header and Footer dialog box. Under Header and Footer, type values in the Left, Center, and Right boxes, as needed. Or, click the arrows next to each position and select an option from the list. For example, to show the file name in the top center of the page, select File name. The box displays a variable that will be replaced with the file name when the page is printed. Headers and footers created in Print Preview appear only in print.
[image: ]
Exhibit 5-5: The Header and Footer dialog box
[bookmark: _Toc342410069]PrintingWorking with pages	5–11

After you’ve previewed your document and confirmed that its content and layout are correct, you’re ready to print. You can print from inside the Print Preview window by clicking the Print button. If Print Preview is not open and you’re ready to print, click the File tab and then select the Print category. Then click Quick Print to send the document to the default printer, or click Print to open the Print dialog box, shown in Exhibit 5-6. In the Print dialog box, you can select the printer and choose which pages to print and the number of copies to print. Click OK to send the document to the selected printer. You can also press Ctrl+P to open the Print dialog box.
[image: ]
Exhibit 5-6: The Print dialog box
[bookmark: _Toc342410070]Topic B: Working with background pages$$
You can use background pages to display information you want to repeat on multiple pages in a drawing.
[bookmark: _Toc342410071]Background pages $$  DESIGN tab    Background and / orBorders & titles
Background pages provide additional information for foreground pages. When you designate a page as background, the fields you add to the page appear on multiple foreground pages, as illustrated in Exhibit 5-7. You can use background pages to consistently display important information such as a company logo or page numbers.
You can have more than one background page in a file, but you can apply only one background page to a foreground page. The same background page is automatically applied to each new page that you add to a drawing. You can use the Page Properties tab in the Page Setup dialog box to remove a background page from a foreground page.
You can use background pages to create headers and footers in your drawings. These differ from headers and footers created in Print Preview, which only appear in print. When you create headers and footers using a background page, the content appears on each drawing page.

[image: ]Drawing pages
Background page

Exhibit 5-7: A background page and foreground pages
[bookmark: _Toc342410072]Fields$$
Fields are variables that provide information about a drawing, such as the company name, the file name, or the file’s author. You can also use fields to display information such as the current date and page numbers. Field data is automatically updated in a drawing. After you add fields, you can format them as ordinary text.
To add a field:
1. Create a text box or select an existing text box.
1. On the Insert tab, click Field to open the Field dialog box, shown in Exhibit 5-8.
1. In the Category list, select a category for the information you want to add.
1. In the Field name list, select a field.
1. Click OK. Repeat these steps to add more fields.
1. [image: ]
1. [image: ]
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Exhibit 5-8: The Field dialog box Page breaks
[bookmark: _Toc342410073]Page breaks$$
Displaying page breaks can help you arrange items in a drawing. With page breaks showing, you can avoid placing objects or fields too close to margins. Page breaks are determined by the page’s print margins.
[bookmark: _Toc342410074]Applying background pages to drawing pages$$
After you create a background page, you can apply it to any drawing page. You need to manually apply each background page to the desired drawing page by using the Page Properties tab in the Page Setup dialog box. After you apply a background page, each new foreground page that you add to the drawing will use this same background.
[bookmark: _Toc342410075]Editing background pages$$
You can edit the lines and shapes on a background page in the same way you would edit them on a foreground page. You can also add graphics, such as a logo, to a background page.
To insert a graphic on a page:
1. On the Insert tab, click Picture. The Insert Picture dialog box opens.
1. Navigate to the location of the file you want to insert.
1. Select the file and click Open. (Or double-click the file.)
1. Resize and position the graphic if necessary.
[bookmark: _Toc342410076]Topic C: Working with links
When you create a complex drawing in Visio, the drawing might extend over several pages. If this happens, you can link the pages. You can also link diagrams to other Visio files, to Internet addresses, or to files of other types, such as Excel worksheets.
[bookmark: _Toc342410077]Hyperlinks$$
Hyperlinks connect a shape to another page, an external file, an Internet address, or a network address. To link a shape to another page or external resource:
1. Select the shape that you want to contain a hyperlink.
1. On the Insert tab, click Hyperlink to open the Hyperlinks dialog box, shown in Exhibit 5-9.
1. In the Address box, enter an Internet address or the path of the file to which you want to link. Or, click Browse to navigate to the file you want to link to.
1. Click OK.
[image: ]
Exhibit 5-9: The Hyperlinks dialog box
[bookmark: _Toc342410078]Linking to detail pages$$
When a drawing does not fit on one page, you can create additional pages, each containing varying degrees of detail. Typically, you begin with an overview and then expand the detail based on logical sections. For example, the main drawing page might depict an organization’s structure, and additional pages would show the structure of the various departments. You can then link shapes from the main page to detail pages by using the Sub-address field in the Hyperlinks dialog box.
[bookmark: _Toc342410079]Testing links in Visio
To test your links, press and hold the Ctrl key and then click the shape that contains the link. Page links will open in the same Visio window. Links to external files open in a new Visio window.
[bookmark: _Toc342410080]Link multiple files
You can link multiple files to a single shape. This is helpful if there are several files that are related to one shape in a drawing. To link a shape to multiple files, select the shape, open the Hyperlinks dialog box, and click New. Then create the desired links and click OK. To delete a link, select the link in the Hyperlinks dialog box and click Delete.
[bookmark: _Toc342410081]Linking to other file types
If you have supporting information in another format, such as an Excel worksheet, you can link your Visio drawing to it. You can also designate a specific location that the linked file should display when it opens.
[bookmark: _Toc342410082]Unit 6 - Network and brainstorming diagrams
Complete this unit, and you’ll know how to:
Create and modify network diagrams.
Create and modify rack diagrams.
Create brainstorming diagrams, and import and export XML data. Limité à BRAINSTORMING !
[bookmark: _Toc342410083]Topic A: Network diagrams
Explanation	Visio makes it easy to illustrate complex network layouts for documentation and visualization purposes. A clear and well-documented network diagram is helpful to a network administrator.
[bookmark: _Toc342410084]Network shapes
Many of Visio’s network diagram shapes are industry-standard topology shapes. Topology shapes represent industry configurations such as ring and pipeline topologies often used in a network designs. These shapes provide connection points for the devices that are arranged according to the network layout. Because these are industry-standard shapes, their use in network diagrams ensures common understanding.
Topology shapes have square shape handles at their ends and in the middle, as shown in Exhibit 6-1. They also have diamond-shaped connection handles that you can use to connect to other shapes.
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Exhibit 6-1: Examples of topology shapes
[bookmark: _Toc342410085]Working with connection handles
When you’re working with topology shapes, you can create additional connections to expand the network diagram. Simply drag a yellow diamond connection handle from inside the shape, as shown in Exhibit 6-2. You can also move connection handles by dragging them to new locations.
[image: ]
Exhibit 6-2: Creating a new connection
[bookmark: _Toc342410086]Add and connect topology shapes
You can add more topology shapes to a diagram in several ways. You can drag a shape from the stencil, copy and paste a shape, or press the Ctrl key while dragging a shape already on the drawing page. When you create a duplicate of a topology shape, the duplicate maintains the same shape connections as the original. If you want a duplicate that has no connections, then duplicate the shape before using the connection handles or drag a new shape from a stencil. If you add a shape from a stencil, you can often quickly make connections by using the AutoConnect feature.
[bookmark: _Toc342410087]Hide extra connection lines
Topology shapes will often have connection lines that you don’t need. You can hide extra connections by dragging the connection handles to the center of the shape. The connection handles are still visible when the shape is selected, but the lines are hidden, as shown in Exhibit 6-4.
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Exhibit 6-3: Hiding an extra connection handle
[bookmark: _Toc342410088]Move shape text
In addition to using the Text tool to move text blocks, many shapes provide control handles that you can use to move shape text interactively. To move shape text, select the shape whose text you want to move, and then drag the yellow control handle to the new text location. Moving text can often improve the readability of your diagram, especially if the text overlaps lines or other shapes.
[bookmark: _Toc342410089]Topic B: Rack diagrams
You can create diagrams to show the structure of a rack system. Network administrators use rack diagrams to show or model the configuration of computer components. They also use them to optimize storage space because they can clearly view the space requirements for each component.
[bookmark: _Toc342410090]Creating rack diagrams$$
A rack diagram documents a rack system, as shown in Exhibit 6-4. A rack system is a collection of computer hardware devices and components mounted in a rack. Visio’s network equipment shapes conform to industry standards and are designed to fit together precisely. The rack diagram template is available in the Network category.
[image: ]
Exhibit 6-4: A rack diagramn
[bookmark: _Toc342410091]Topic C: Brainstorming diagrams$$
Brainstorming is a method commonly used to solve problems or generate ideas. You can use Visio to document a brainstorming session to help you to capture ideas, evaluate options, and determine the best course of action.
[bookmark: _Toc342410092]Elements of a brainstorming diagram
In a brainstorming diagram, the main topic represents the central problem statement or the core heading that forms the basis for planning. For example, to document ideas for new products, the main topic in a brainstorming session might be “New product line.” Topics are consideration points or factors that you need to discuss to solve the problem.
Legend shapes provide additional information about the items in a diagram, such as the priority level, exceptions, or a factor that you define. When you add Legend shapes to a diagram, the legend is automatically updated.
[bookmark: _Toc342410093]The Brainstorming tab
When you create a file based on the Brainstorming template, the Brainstorming tab appears on the Ribbon. This tab contains commands you can use to create and manage brainstorming diagrams. The following table describes some of the commands on the Brainstorming tab.
	Command
	Description

	Auto-Arrange
	Automatically arranges topics in a brainstorming diagram.

	Main
	Inserts a Main Topic shape in the diagram.

	Subtopic
	Attaches a subtopic to the selected topic.

	Peer
	Inserts a topic at the same level as the selected topic.

	Multiple Subtopics
	Opens the Add Multiple Subtopics dialog box, which you can use to insert several subtopics simultaneously.

	Change Topic
	Opens the Change Shape dialog box, which you can use to change the shape of a selected topic.


[bookmark: _Toc342410094]Creating brainstorming diagramsµµ
As mentioned earlier, brainstorming diagrams provide a visual way of understanding a problem and potential solutions. For example, if you’re the manager of an organization and you need to determine how to most effectively allocate resources among various departments, you can create a brainstorming diagram that shows all the departments, similar to the example shown in Exhibit 6-5. Then, you can experiment with various resource allocations to visualize possible solutions.
[image: ]
Exhibit 6-5: A brainstorming diagram
[bookmark: _Toc342410095] Applying brainstorming data
You can export
the data in a brainstorming diagram to a Microsoft Word document, a Microsoft Excel workbook, or an XML file. XML stands for Extensible Markup Language and is a widely accepted standard for exchanging data across applications and platforms.
To export a brainstorming diagram to an XML file:
1. Open the brainstorming diagram you want to export.
1. On the Brainstorming tab, click Export Data and choose To XML. The File Save dialog box opens.
1. Navigate to the location where you want to save the XML file.
1. Click Save. Visio exports the data to XML. A message box appears indicating that the export is complete.
1. Click OK.
You can Import XML
Visio’s XML import and export features allow you to exchange XML data between Visio and many other applications. XML data is simple text made up of tags that describe the data they contain. Exhibit 6-6 shows the XML in the file “Organization structure.xml” when viewed in Notepad, the default text editor in Windows. Visio can display this XML data as a brainstorming diagram when you import the file.
[image: ]
Exhibit 6-6: XML data viewed in Notepad
To import XML data into a brainstorming diagram:
1. Create a drawing based on the Brainstorming Diagram template.
1. On the Brainstorming tab, click Import Data. The File Open dialog box appears.
1. Navigate to the location of the XML file you want to import.
1. Double-click the file, or select it and click Open.
BPMN support in Visio 2010$$
Business Process Modeling Notation (BPMN) is a standard maintained by the Object Management Group which gives businesses the ability to understand their business processes using a graphical notation and to communicate these processes in a uniform manner. The basic BPMN shapes are similar to traditional flowcharting shapes, which makes modeling in BPMN easy for new users. For advanced users, the BPMN standard contains a large number of detailed shapes—more specialized versions of the basic shapes—which are useful when modeling complex interactions or precise behaviors within a process.
Companies have told us that they would like to enforce a standardized notation, like BPMN, within their organization to ensure that processes are graphically expressed in a consistent manner. Based on this feedback, we introduced the following support for BPMN in Visio 2010.
We support all shapes defined in the BPMN 1.2 standard.
Our BPMN shapes have associated element attributes, as specified by the standard.
Using Diagram Validation, a user can check the visual correctness of a diagram against logical rules specified in the standard.
You can find the BPMN Diagram template under the Flowchart category on the New tab of the Backstage View.


[image: Backstage]
The BPMN Diagram template contains five stencils of BPMN shapes: the BPMN Basic Shapes, BPMN Events, BPMN Activities, BPMN Gateways and BPMN Connecting Objects stencils.
[image: Stencils]
For new BPMN users, all the basic BPMN shapes are located on the BPMN Basic Shapes stencil. For more advanced users, additional BPMN shapes can be derived from the basic shapes or taken from the other BPMN stencils.
You can derive a more specialized shape from a basic shape by right-clicking on the shape. The menu below shows how you would change a Task to a Standard Loop Task or a Multi-Instance Loop Task. Each of these shapes have different graphical symbols to distinguish them and different BPMN properties, or attributes, associated with them.
[image: RMA]
Notice the BPMN Attributes… option located at the bottom of the above menu. This option launches the Shape Data window which displays the shape’s BPMN attributes, properties specified by the BPMN standard. This gives advanced BPMN users to option to edit the complete set of BPMN attributes associated with a shape.
[image: Shape Data]
The BPMN Diagram template and shapes take advantage of many of the new Visio 2010 features. You will notice that the ease of use and flowcharting improvements in Visio 2010 make it easy to build visually-appealing BPMN diagrams. Below, we focus on some of the other Visio 2010 features that you will encounter when using the BPMN template and shapes.
Diagram Validation
The BPMN standard contains a large number of rules about the visual, structural and semantic properties of a diagram: these rules must be satisfied in order to comply with the standard. The standard documentation is long and it is hard for new users to understand its intricacies. We use Diagram Validation to help users ensure that their BPMN diagrams are visually conformant with the standard.
The BPMN Diagram template includes validation rules based on the BPMN 1.2 standard. This means that you can use theCheck Diagram button on the Process tab to check for visual issues with your BPMN diagram. After you validate your diagram, any issues are listed in an Issues window.
[image: Validation]
[image: C:\Users\danie\AppData\Local\Temp\SNAGHTML179b319.PNG]
To easily find shapes with issues, you can click on an issue and the corresponding shape will be selected. Once you fix the issues, you can check the diagram again to confirm that there are no longer any problems. This makes it much easier to create a BPMN-compliant diagram.
Containers
Expanded Sub-Process and Group shapes in the BPMN template are Containers. This means you can take advantage of all the built-in container logic. For example, when you move an Expanded Sub-Process, all the member shapes move automatically. In addition, when you select an Expanded Sub-Process or Group, you see the containers contextual tab, which gives you the ability to further customize these shapes.


[image: Contextual Tab]
Callouts
The Text Annotation shape in the BPMN template is a Callout. A callout points at or references another shape, which we call the “target” of the callout. When a target shape is moved, copied or deleted, any callouts attached to the shape will be moved, copied or deleted too.  Thus callouts stay with their target shapes, though you can reposition the callout to any offset from its target.
[image: C:\Users\danie\AppData\Local\Temp\SNAGHTML185d1e2.PNG]
The callout is linked to the shape
[image: Text Annotation]
Cross-functional Flowcharts
The Pool /Lane shape in the BPMN template allows you to add a Pool or Lane shape to your diagram. This shape is based on our Cross-functional Flowchart (CFF) shape, which means that Pools and Lanes are easy to manipulate using CFF functionality. For example, to add more lanes, you can mouse along the edge of the cross-functional flowchart to where you want to add the lane and a blue arrow will appear. Click on the blue arrow and voila, you have a new lane!
[image: CFF]
The BPMN template combines a large number of new Visio 2010 features to make building BPMN-compliant diagrams easier. Both new and advanced BPMN users will benefit from the depth of functionality available while using this template.
[image: ]
[bookmark: _Toc342410096]Unit 7 - Customization and reporting
Complete this unit, and you’ll know how to:
$$Use guides to arrange objects, and customize shape connections.
Set shape properties and create and apply custom properties.
Create and modify property reports.
[bookmark: _Toc342410097]Topic A: Layout and connection techniques
You can add guides to a drawing page to make it easier to position and align shapes precisely. Other techniques you can use to fine-tune a diagram include creating your own connection points on shapes and formatting connectors to clarify a message.
[bookmark: _Toc342410098]Guides
Guides are non-printing lines that divide a drawing page into sections to help you precisely arrange shapes and lines. For example, Exhibit 7-1 shows three horizontal guides and one vertical guide. You can add guides to a drawing by dragging from the horizontal or vertical ruler onto the page. Guides are development aids only; they are not part of the final product and do not print. You can move guides as needed by dragging them on the page.
[image: ]
Exhibit 7-1: One vertical and three horizontal guides Gluing shapes to guides
Just as you glue shapes to connector lines, you can glue shapes to guides. This technique can help you to align objects precisely and move multiple shapes in unison.
It’s typically best to place guides before adding shapes to a drawing page. If you place guides on a drawing page that already contains shapes, you’ll need to manually reposition the shapes on the guide to glue them. If you glue multiple shapes to a guide, all the shapes will move together if you move the guide.
[bookmark: _Toc342410099]Creating new connection points
Most shapes have only one connection point on each side. If you want to create your own connection points, select the Connection Point tool on the Home tab. To add connection points, click the shape to select it. Then, press and hold Ctrl and click where you want to add the connection point. To remove a connection point, click it to select it and press Delete. You can move connection points by dragging them with the Connection Point tool.
[bookmark: _Toc342410100]Select objects by Type$$
Sometimes you might want to select similar objects and shapes. For example, you might be working on a complex drawing and need to select multiple objects of the same type for editing. You can select each shape one by one, or you can use the Select by Type dialog box, shown in Exhibit 7-2. To open this dialog box, click Select in the Editing group on the Home tab, and choose Select by Type.
[image: C:\Users\danie\AppData\Local\Temp\SNAGHTML15b2032.PNG]
[image: ]
Exhibit 7-2: The Select by Type dialog box
[bookmark: _Toc342410101]Shape connections
You can connect shapes to new connection points by using the same techniques you would use to connect unaltered shapes. However, if you want to precisely position the connections, you can use the Connector tool to draw the connections manually. AutoConnecting the shapes can produce undesired results. If you’ve already positioned shapes in a drawing, using the Connector tool can often produce better results.
[bookmark: _Toc342410102]Snap & Glue$$Customization and reporting	7–11

By default, when you position and adjust objects in a drawing, they snap to different items, such as the grid or ruler subdivisions. You can modify glue settings to use other parts of selected shapes as well.
Glue settings
You can use more than connection points to glue shapes. For example, you can glue to shape handles instead of, or in addition to, gluing to connection points. To control the way items snap, use the Snap & Glue dialog box, shown in Exhibit 7-3. To open the Snap & Glue dialog box, click the View tab and then click the dialog box launcher in the Visual Aids group.
[image: ]
[image: ]
Exhibit 7-3: The Snap & Glue dialog box
[bookmark: _Toc342410103]Topic B: Shape properties
You can define properties to store and track information about elements of a drawing.
For example, you can store information about a server, such as its manufacturer, CPU speed, hard drive space, and IP address.
[bookmark: _Toc342410104]Define shape properties
There are several pre-defined properties that you can set, as shown in Exhibit 7-4. You can also create custom properties. To define properties for a shape:
1. Right-click the shape and choose Properties to open the Shape Data panel.
1. In the appropriate data fields, enter the information you want to track.
1. Click the “X” in the corner to close the panel, if necessary.
[image: ]
Exhibit 7-4: The Shape Data panel
[bookmark: _Toc342410105]Custom properties
As mentioned earlier, all shapes have a predefined set of fields you can use to set properties. However, you might want to store information that isn’t defined in the default set. You can create one or more custom properties to track information that’s important to you or your organization. You can apply custom properties to multiple shapes.
To create a property set:
1. Right-click in the Shape Data panel and choose Shape Data Sets to open the Shape Data Sets panel, shown in Exhibit 7-5.
Click Add to open the Add Shape Data Set window.
Enter a descriptive name for the property set, select “Create a new set,” and click OK.
[image: ]
Exhibit 7-5: The Shape Data Sets panel
To add custom properties to a property set:
1. In the Shape Data Sets panel, select the property set you want to define custom properties for.
1. Click Define to open the Define Shape Data dialog box, shown in Exhibit 7-6.
1. Specify the information for the property.
1. Click New to add the property and reset the dialog box.
1. Using the same steps, add more properties if needed.
1. Click OK to close the dialog box.
[image: ]
Exhibit 7-6: The Define Shape Data dialog box Custom properties for individual shapes
When you create custom properties for a shape, the custom properties will be associated with that shape only. However, you can copy the properties of an individual shape into a custom property set if you want to use them for other shapes.
[bookmark: _Toc342410106]Applying custom properties
After creating a custom property set, you can apply the properties to the shapes in your drawing. The new property set will be added to the existing property set for the shape.
To apply a custom property set to a shape:
1. Select the shape to which you want to apply the custom property set.
1. In the Shape Data Sets panel, check each property set you want to add to the selected shape.
1. Select whether to apply the checked property set(s) to shapes selected in the drawing or to shapes selected in the stencil.
1. If you want to remove a property set, check “Remove existing data sets.”
1. Click Apply.
[bookmark: _Toc342410107]Topic C: Reporting
You can include shape property data in a drawing report. You can also modify a report, sort data, format report shapes, and update a report with modified data.
[bookmark: _Toc342410108]Creating reports
To create a report, you use the Report Definition Wizard, which guides you through the steps for creating a report. As you create a report, you define the information that will be included and the layout for displaying and sorting the data.
To run the Report Definition Wizard:
1. $$On the Review tab, click Shape Reports to open the Reports dialog box, shown in Exhibit 7-7.
1. Click New to open the Report Definition Wizard.
1. Make the selections you want on each page of the wizard, and click Next to continue to the next page.
1. Click Finish to close the wizard.
[image: ]
Exhibit 7-7: The Reports dialog box
[bookmark: _Toc342410109]Running reports
After you’ve defined a report, you need to run it to view the results. To run a report:
1. If necessary, open the Reports dialog box.
1. In the list, select the report you want to run.
1. Click Run to open the Run Report dialog box, shown in Exhibit 7-8.
1. From the list, select the format you want for the report. In order to add the report as a shape within a Visio drawing, you must have Microsoft Excel installed on your computer.
1. Select whether you want to create a copy of the report or specify a link to the report.
1. Click OK.
[image: ]
Exhibit 7-8: The Run Report dialog box
[bookmark: _Toc342410110]Report updates
You might need to update a report for a variety of reasons, such as changes in values or the addition of new shapes to a drawing. The process for updating a report will depend on the modifications you want to make.
Linked reports
If you link a report to a shape containing property data, when you run the report, you can update any property data that has changed. To do so, right-click the report and choose Update Report.
[bookmark: _Toc342410111]Modifying a Visio Table Report shape
A Visio Table Report shape is actually an embedded Excel worksheet. You can format a Visio Table Report shape with colors other than the default colors used in the cells. Double-click the shape to activate the Excel chart and show Excel commands on the Ribbon. To format a cell, you must first select it by clicking it. If you want to apply formatting to multiple cells, press and hold Shift while selecting each cell and then apply the desired formatting. When you’re finished, press Esc.
[bookmark: _Toc342410112]Course summaryS–1

This summary contains information to help you bring the course to a successful conclusion. Using this information, you will be able to:
Use the summary text to reinforce what you’ve learned in class.
Determine the next courses in this series, as well as any other resources that might help you continue to learn about Visio.
[bookmark: _Toc342410113]Topic A: Course summary
Use the following summary text to reinforce what you’ve learned in class.
[bookmark: _Toc342410114]Unit summaries
Unit 1
In this unit, you learned how to start Visio and create a file. You identified interface components and you learned how to use Visio Help. You also learned how to navigate in a drawing, change view settings, open stencils, move stencils in the Shapes window and float stencils in the drawing window. Then, you learned how to select, move, scale, and resize objects.
Unit 2
In this unit, you learned how to use drawing tools to create different shapes and reshape objects. You learned how to use the Freeform tool, create compound lines, and duplicate, align, and distribute objects. You also learned how to group and rotate shapes.
Unit 3
In this unit, you learned how to plan a basic flowchart. You learned how to create a basic diagram and insert shapes by dragging from stencils and by using AutoConnect. Then you learned how to connect and move shapes, apply different connector types, and insert and format text. You learned how to apply text to individual shapes and connectors, rotate text blocks, and create and modify an organization chart.
Unit 4
In this unit, you learned how to format text and text blocks, control attributes such as font size, text color, margins, alignment, and line spacing, and apply style themes and effects. You learned how to format shapes and lines, apply line and corner styles, create a custom shadow effect, and use the Format Painter to copy formatting to one or more other shapes.
Unit 5
In this unit, you learned how to set file properties, set page and printer settings, use Print Preview, create print headers and footers, and print a drawing. You also learned how to work with background pages, create background headers and footers, and use fields to display information. Then you learned how to apply a background page to a drawing and insert a graphic. Finally, you learned how to add hyperlinks to a drawing.
Unit 6
In this unit, you learned how to create a basic network diagram, move control handles to create different connection points, and move text blocks connected to shapes. Then you learned how to create rack diagrams and brainstorming diagrams. You also learned how to import data into and export data from a diagram.
Unit 7Course summary	S–3

In this unit, you learned how to use guides to precisely align and glue shapes. You also learned how to add new connection points to a shape, select objects by type, and set Snap & Glue options. You learned how to set properties for shapes, create and apply custom properties, and create and run reports. Finally, you learned how to format a report table and update a report.
[bookmark: _Toc342410115]Topic B: Continued learning after class
It is impossible to learn how to use any software completely in a single day. To get the most out of this class, students should begin working with Visio to perform real tasks as soon as possible. We also offer resources for continued learning.
Création de groupe de Templates
Les diagrammes BPMN sont uniquement disponibles dans la version Premium de Visio 2010 donc c'est normal.
Si tu veux créer un modèle qui apparaisse dans une catégorie particulière, la solution la plus simple est :
· Crée un répertoire "C:\MesCatégories"
· Crée tes sous répertoires dans ce répertoire pour chaque catégorie "Catégorie 1","Catégorie 2"
· Copie tes modèles par catégorie dans ces sous-répertoires.
· Rajoute le répertoire "C:\MesCatégories" dans la liste des Chemins des modèles "Fichier=>Options=>Option avancées=>Emplacement des fichiers=>Modèles" ( chaque chemin doit etre séparé d'un autre par un ;)
Pour les gabarits c'est le même principe sauf que la liste est "Fichier=>Options=>Option avancées=>Emplacement des fichiers=>Gabarits"
Bonne continuation.
[bookmark: _GoBack]
[bookmark: _Toc342410116]Miscellaneous
This product is totally free. If you enjoyed it, be nice enough to contribute as you deem that to the charity of your choice
Visit our website www.cadacom.be, everything is free ...
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